Craft Edge

Sure Cuts A Lot Forum
It is currently Wed Nov 26, 2014 2:49 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Mon Nov 28, 2011 2:03 pm 

Joined: Sat Jan 01, 2011 5:42 pm
Posts: 4
If i buy a new Provo Craft Cricut Expression will it work with my Sure cuts a lot 2?


Top
 Profile  
 
PostPosted: Mon Nov 28, 2011 5:29 pm 

Joined: Sun Mar 16, 2008 2:08 pm
Posts: 3808
Location: CALIFORNIA
NO, ProvoCraft stopped SCAL from distributing what they considered competing software.so no SCAL for any ProvoCraft machine unless you already own SCAL and can backdate the Cricut firmware to the last version of SCAL.

See http://CraftEdge.com for a list of the cutters you can use with SCAL. or contact CraftEdge support for more information.

_________________
Susan E
http://creationsbypapasue.blogspot.com
LEARN, GROW, CREATE, SHARE


Mac 10.9.5 Mavericks, eCAL 1.505, Export Plug-in, Inkscape 48, iPad/scal3
eClips1.


Top
 Profile  
 
PostPosted: Mon Nov 28, 2011 8:37 pm 

Joined: Sat Jan 01, 2011 5:42 pm
Posts: 4
I have the old version of SCAL 2 I am just wondering if it will work witha new Cricut Expression??


Top
 Profile  
 
PostPosted: Mon Nov 28, 2011 9:39 pm 

Joined: Sun Mar 16, 2008 2:08 pm
Posts: 3808
Location: CALIFORNIA
Your new E comes with new firmware in the software. SCAL needs an old firmware version. If you can find the firmware vs of yourbExpressions CraftEdge support can tell you if it will work.

Here is the latest version of PC firmware that will work with SCAL2


You are the only person who can change the firmware on your Cricut Personal Cutter, Create, Expression, Cake or Cake Mini. This can only be done by deliberately using the update firmware feature in the older Cricut Design Studio or the new Cricut CraftRoom software programs.

Quote:
If you're happily using SCAL then there is no need to update your Cricut firmware beyond the versions listed below. Keep in mind these are the highest supported firmware version numbers. If yours is a little less, don't worry.
Personal Cutter: 1.34
Create: 1.54
Cake Mini: 1.54
Expression: 2.35
Cake: 2.35
To check your Cricut firmware, just turn it on and watch the display. Depending on the model, you will see something like v.1.3 or v. 1.54 or v.2.3 or v.2.34, etc.

_________________
Susan E
http://creationsbypapasue.blogspot.com
LEARN, GROW, CREATE, SHARE


Mac 10.9.5 Mavericks, eCAL 1.505, Export Plug-in, Inkscape 48, iPad/scal3
eClips1.


Top
 Profile  
 
PostPosted: Wed Nov 30, 2011 12:23 am 

Joined: Sat Nov 26, 2011 1:32 pm
Posts: 425
Location: SoCal (Windows 7, Eclips1, ECAL 1.500, Photoshop, Illustrator
I won't work with the expression 2, but it should work with a regular expression.


Top
 Profile  
 
PostPosted: Mon Dec 12, 2011 2:01 pm 

Joined: Tue Dec 06, 2011 7:35 pm
Posts: 5
I just got a new laptop & installed my old ECW 2 on it to work with my cricut crease but the software shows only York v1.5 and my cricut create shows v1.54. Will I still be able to update SCAL2 and it work b/c I don't know how to take the cricut back?


Top
 Profile  
 
PostPosted: Sun Jan 08, 2012 4:47 pm 

Joined: Mon Sep 28, 2009 3:06 am
Posts: 363
Location: Newport News, VA, USA; SCAL 2.044-Expression; SCAL 3-Cameo; Mac; Inkscape 0.48; GIMP 2.6
I just went through trying to figure out if I should/have to upgrade our Cricut Expression's firmware to use with Cricut CraftRoom. Unfortunately, there are lots of bits and pieces of information which did not clear things up for me. Here's a summary of what I learned.

Cricuct CraftRoom (as of January 2012) wants to upgrade the Cricut Expression firmware to version 2.43.
SCAL 2 verision 2.044 will work with this version of the firmware. I cannot say whether earlier versions will or won't, but there are reports that earlier versions do not.

SCAL only lets you choose firmware version up to 2.3x when you go to cut. Just choose 2.3x.

I hope this helps.

- Jasen.


Top
 Profile  
 
PostPosted: Fri Mar 30, 2012 12:26 pm 

Joined: Wed May 25, 2011 4:13 pm
Posts: 17
is it possible to back up a cricut update to an older version, my accidentally got updated to 1.54 and won't work with SCAL 2 anymore unless I can make it go back to 1.51....


Top
 Profile  
 
PostPosted: Fri Mar 30, 2012 12:55 pm 

Joined: Mon Oct 12, 2009 5:01 am
Posts: 4465
In this post above...it states that 1.54 for the Create will work...perhaps you just need to go through the unplug replug everything and also make sure no other programs are open at the same time as scal. Open scal and then turn on your cutter and listen for the recognition ding and then go from there.

_________________
My pictures and files are available for a limited time only.


Top
 Profile  
 
PostPosted: Mon Aug 06, 2012 6:22 am 

Joined: Mon Aug 06, 2012 3:47 am
Posts: 2
papasue wrote:
Your new E comes with new firmware in the software. SCAL needs an old firmware version. If you can find the firmware vs of yourbExpressions CraftEdge support can tell you if it will work.

Here is the latest version of PC firmware that will work with SCAL2


You are the only person who can change the firmware on your Cricut Personal Cutter, Create, Expression, Cake or Cake Mini. This can only be done by deliberately using the update firmware feature in the older Cricut Design Studio or the new Cricut CraftRoom software programs.

Quote:
If you're happily using SCAL then there is no need to update your Cricut firmware beyond the versions listed below. Keep in mind these are the highest supported firmware version numbers. If yours is a little less, don't worry.
Personal Cutter: 1.34
Create: 1.54
Cake Mini: 1.54
Expression: 2.35
Cake: 2.35
To check your Cricut firmware, just turn it on and watch the display. Depending on the model, you will see something like v.1.3 or v. 1.54 or v.2.3 or v.2.34, etc.


Hi, I have a personal cutter with 1.0 v........SCAL2 is not cutting , it shows "an error ocurred while trying to cut", I am thinking that it could be the firmware but could be something else that I don't know. If I update right know, it would be 1.34v................will it work with SCAL2???? My SCAL says that it has to be 1.2 or 1.3 to work but 1.34v is the same as 1.3v???? thanks for any help!!!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next

All times are UTC - 8 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group