this is so frustrating!!!! sizzix eclips problem

Post Reply
mariliax00
Posts: 3
Joined: Thu Dec 01, 2016 2:42 am

this is so frustrating!!!! sizzix eclips problem

Post by mariliax00 »

Hi everyone,
I have to say I m very disappointed with this issue I have to deal with for the 3rd time!
My sizzix eclips yet AGAIN has stopped working properly. Just like many of you out there I am dealing with the same problem:my machine starts the working process once I feed in the mat & press cut, and within a second's time it freezes spits out the cutting mat and switches off on its own. I am an experienced user and have tried removing software and updating software but nothing seems to work.
I find it absolutely outrageous that after having contacted Sizzix UK they are not able to provide me with a solution, and will neither replace or refund me. I have pending orders to deliver and am now stuck with not much to be done.
I find it hard to believe that after 3 replacements Sizzix is not even interested to provide me with a solution. :shock:
These machines are not exactly a give away, we have all invested money, and to top things up I have ended up paying tremendous amounts of money for new mats & cutting blades to try and solve the problem.
Unfortunately this is very disappointing for me and has left me with a very bitter experience which I have to tell all my crafting friends around the globe about.

If anyone of you has encountered the same problem and has found a solution PLEASE post it here for us.
As I said, I have Christmas pre orders pending and am very desperate to solve this issue asap.
Thank you
Marilia (Greece)

sstehman
Posts: 1964
Joined: Wed Dec 01, 2010 4:29 pm
Location: Sandy in PA (PC&MAC,Inkscape .48, SCAL2,eClips, eCAL)

Re: this is so frustrating!!!! sizzix eclips problem

Post by sstehman »

Have you contacted Sizzix directly through their website? I had an issue with my original one that was replaced and have not had a problem since then. If it has been replaced 3 times, perhaps contacting the US office might get a response through to your home office.

Sounds like you might use it pretty heavily. Make sure there is not any paper stuck near the sensor area and never get water in that area as that is where the motherboard is located. It should be a small blackish colored section at the left rear of the roller. You can clean with a lint free cloth.

Wish I had a better answer for you.
Sandy in PA

mariliax00
Posts: 3
Joined: Thu Dec 01, 2016 2:42 am

Re: this is so frustrating!!!! sizzix eclips problem

Post by mariliax00 »

Hi Sandy thanks for your reply to my message.
I have never used water on the machine as water on its own is destructive for any electronic machines.
As for me using the machine heavily, that doesn't apply. I only use it for Christmas period which means only using it one time per year, plus I do not choose to cut complicated svgs with lots of detail on purpose not to give my machine problems.
I have checked the machine thoroughly for paper debris and there is nothing there, I try to keep all my equipment in perfect condition on a daily basis.
This is why I am so frustrated with this issue.
It was very impressive though to say the least, that Sizzix UK was actually unable to provide me with a solution since they are the support for Europe's Sizzix. Their reply was: "unfortunately we do not stock these machines anymore and we cnnot provide you with a solution to your problem"!!!
If anyone else has the same problem please share any possible solutions.
Thank you
Marilia

byronsterb
Posts: 5
Joined: Mon Apr 29, 2019 7:20 pm
Location: Norway
Contact:

this is so frustrating sizzix eclips problem

Post by byronsterb »

not installed anything for months... its just happened over the past couple of days

gaso
Posts: 11
Joined: Fri May 17, 2019 8:55 am

Re: this is so frustrating!!!! sizzix eclips problem

Post by gaso »

Good point: "These machines are not exactly a give away"

Post Reply