Craft Edge

Sure Cuts A Lot Forum
It is currently Sat Mar 28, 2020 12:54 pm

All times are UTC - 8 hours

Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Fri Mar 01, 2013 9:40 pm 
Site Admin

Joined: Tue Jul 05, 2011 10:34 pm
Posts: 353
If your copy of Sure Cuts A Lot 3 is not starting up and just quickly flashes the opening logo screen and then closes, make sure you have the latest 3.048 (or higher) installed from

If after installing the update and it still does not start, please try the following:
Immediately after starting Sure Cuts A Lot, hold down the 'D' key on the keyboard in Windows or the 'Control" key on a Mac. Keep it held down and after a few seconds, it should ask to load default settings. Click ok and see if it loads then.

- Craft Edge

PostPosted: Sat Mar 02, 2013 6:42 am 

Joined: Wed Oct 31, 2012 9:20 am
Posts: 39
Hi My SCAL will start up but every time I first get a user control window that asks me if I give premission for the unknow publisher to make changes to my computer I click yes and then Scal will start up. I tried downloading again and restarting my computer and still the same. During the re install of 3.048 I got the attached error message. Should I do the same procedure listed above to fix this problem or is there something else I should do.

Susan ;)

4.JPG [ 29.54 KiB | Viewed 12290 times ]

PostPosted: Sun Mar 03, 2013 9:50 pm 

Joined: Thu Feb 21, 2013 1:22 pm
Posts: 2
I love this forum! I sat down to do some cutting this afternoon and found that my SCAL 3.047 suddenly refused to boot past the opening logo window. After learning a lot while searching the forum, I found that the answer was just posted by CraftEdge - see their post above to UPDATE to version 3.148. I downloaded, installed and am up and cutting. thanks again.

each day is a gift
Windows XP, SCAL 3.048, Master VC2000 cutter, Cricut Express, SCAL 2.043, Paint Shop Pro 8

PostPosted: Fri May 24, 2013 4:28 pm 

Joined: Mon Sep 12, 2011 11:49 am
Posts: 2
Thanks for this tip. I upgraded to the latest version of SCAL and was getting the message that it had stopped working
This has solved my problem
Once again Thank You x

:D :D :D

PostPosted: Fri Oct 25, 2013 4:18 am 

Joined: Sun Dec 27, 2009 6:04 pm
Posts: 193
I tried to open my SCAL3 and it says I have to activate it. I have went back to the support/upgrade 3 and it says I have already received the activation. Now what do I do. I really need to get this working. Thanks

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 8 hours

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group