Craft Edge
http://forum.surecutsalot.com/

My Cricut Expression Version 2.31
http://forum.surecutsalot.com/viewtopic.php?f=6&t=12157
Page 1 of 2

Author:  alang79 [ Sun Apr 25, 2010 1:43 am ]
Post subject:  My Cricut Expression Version 2.31

When i want to cut with SCAL, SCAL only give me two option either Cricut Expression 2.1V or 2.3V for firmware version.
While my cricut version 2.31. So, it's doesnt support to cut the project even i istalled already USB Driver

Anyone can help me how solve this problem so i can use SCAL to cut with my cricut expression (2.31 Version)

u can email me too in zazrizal@hotmail.com

THANK YOU FRIENDS

Author:  kelsie94 [ Sun Apr 25, 2010 3:51 am ]
Post subject:  Re: My Cricut Expression Version 2.31

I could not get scal to work when I was using 2.3, so I switched to 2.1 and it works great!

Author:  suzsh [ Sun Apr 25, 2010 12:14 pm ]
Post subject:  Re: My Cricut Expression Version 2.31

I have version 2.31 and my scal works fine. Hmmm. I have version 2.12 for scal2

Author:  alang79 [ Mon Apr 26, 2010 4:51 am ]
Post subject:  Re: My Cricut Expression Version 2.31

My SCAL Version is 2.012

Is it not support because suzsh reply that you use 2.12 for SCAL and its work fine with the cricut version 2.31

can i upgrade my SCAL version in Scrapingtbale.com?
as i know, the latest version for SCAL is 2.012

ermmm help me friends out there...

Author:  alang79 [ Mon Apr 26, 2010 4:57 am ]
Post subject:  Re: My Cricut Expression Version 2.31

dear Suzh,

Can i ask you, where you get SCAL2 version 2.12 as you mention in my problem post?

I have SCAL2 version 2.012 and cant support with cricut expression version 2.31...im so frust

Author:  suzsh [ Mon Apr 26, 2010 6:10 am ]
Post subject:  Re: My Cricut Expression Version 2.31

My typo mistake! I have 2.012

why do you say the expression is not
supported? What goes your computer
tell you? Are you able to send the cut
to the expression?

Author:  alang79 [ Mon Apr 26, 2010 7:04 am ]
Post subject:  Re: My Cricut Expression Version 2.31

When i On my Cricut Version 2.31 and connect USB to my laptop,

On cricut screen appear "Cricut (R) Simply Sweet" V1.0 loaded
then i can't load paper

what its does mean?

i dont understand

then i can't cut by using SCAL2 because it can't detect the version 2.31
it only 2 option either Cricut Expression 2.1 or 2.3 only

Help me, how

Author:  alang79 [ Mon Apr 26, 2010 7:38 am ]
Post subject:  Re: My Cricut Expression Version 2.31

Kelsie,

How you switch your cricut from 2.3 to 2.1? Do you have any software to switch the version of cricut?

or you change the cricut?

Author:  AnointedHands [ Mon Apr 26, 2010 8:02 am ]
Post subject:  Re: My Cricut Expression Version 2.31

Check Edit>Pref and under the Cutter tab, if Remeber Cricut Model is checked, uncheck it.

Try to cut again and it will ask you for the firmware version and there is a drop-down arrow if you need to change the version. I would suggest trying the 2.3 first and then if that doesn't work, try the 2.1. As far as I know, SCAL has been working with all the Cricut firmware versions.

HTH
Althea

Author:  HeatherM [ Mon Apr 26, 2010 8:04 am ]
Post subject:  Re: My Cricut Expression Version 2.31

The firmware requirements should really read 2.1x or 2.3x. I use XP and Win7 64 bit with my 2.31 Expression with no problems. I just select the 2.3 firmware option when you cut. If it doesn't ask you for the firmware version, change the preference (at least temporarily) in the SCAL preferences (Edit/Preferences Cutter tab) to ask for model and firmware. If you only use one machine, you can change that back after you get it set up correctly.

If your Cricut won't load the mat when the USB cable is connected, you might have a problem with your Cricut. Does the trial version of DS work for you?
Attachment:
cricut preferences.PNG
cricut preferences.PNG [ 12.61 KiB | Viewed 3063 times ]

Page 1 of 2 All times are UTC - 8 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/