Sizzix eclips + Sure Cuts a Lot

Discuss various cutting machines for SCAL
Post Reply
jewellstwo
Posts: 4
Joined: Tue Nov 22, 2011 7:46 pm

Re: Sizzix eclips + Sure Cuts a Lot

Post by jewellstwo »

lizhagag wrote:
melchache wrote:
jearise wrote:May I inquire as to where you bought it from and if it's a disk or download? I am still waiting to hear from Oh My Crafts that is has been shipped. They told me last week that I am suppose to get a disk copy. I'm jealous and a little mad now. :cry:


i too bought the disk version from ohmycrafts,but so far no email to say it has been shipped :cry:

same here i bought mine from ohmycrafts and still waiting :(

I received mine from OH my crafts just yesterday. Hope you did to.

jewellstwo
Posts: 4
Joined: Tue Nov 22, 2011 7:46 pm

Re: Sizzix eclips + Sure Cuts a Lot

Post by jewellstwo »

I also am unable to install driver, and mine is the full version with registration #. I can't play either.

manangoes
Posts: 3
Joined: Wed Nov 23, 2011 5:32 pm

Re: Sizzix eclips + Sure Cuts a Lot

Post by manangoes »

jewellstwo wrote:I also am unable to install driver, and mine is the full version with registration #. I can't play either.
I just worked it out. Here is what I did.
Plugged in and turned on Eclips. Windows searched for driver and failed to install it.
I went to control panel and clicked on device manager.
Chose the 'unkown device' and chose to install device manually from my computer.
When it asked whereabouts on my computer I went to program files/craft edge/eclips/drivers as that is where I installed it. It found the driver and voila! :) Now I am happy :D
Hope it works for you too - I think I put down all the steps I did but I'm not sure as I was trying heaps of things to try and get it to work. Good luck, let me know how you go.

craftedge
Site Admin
Posts: 353
Joined: Tue Jul 05, 2011 10:34 pm

Re: Sizzix eclips + Sure Cuts a Lot

Post by craftedge »

If you are getting a driver install error, download and install again from
http://www.craftedge.com/download
and then try to install the driver again

melchache
Posts: 41
Joined: Thu May 01, 2008 11:33 am

Re: Sizzix eclips + Sure Cuts a Lot

Post by melchache »

manangoes wrote:
jewellstwo wrote:I also am unable to install driver, and mine is the full version with registration #. I can't play either.
I just worked it out. Here is what I did.
Plugged in and turned on Eclips. Windows searched for driver and failed to install it.
I went to control panel and clicked on device manager.
Chose the 'unkown device' and chose to install device manually from my computer.
When it asked whereabouts on my computer I went to program files/craft edge/eclips/drivers as that is where I installed it. It found the driver and voila! :) Now I am happy :D
Hope it works for you too - I think I put down all the steps I did but I'm not sure as I was trying heaps of things to try and get it to work. Good luck, let me know how you go.
tried that,but don,t see where it says to install manually.

melchache
Posts: 41
Joined: Thu May 01, 2008 11:33 am

Re: Sizzix eclips + Sure Cuts a Lot

Post by melchache »

craftedge wrote:If you are getting a driver install error, download and install again from
http://www.craftedge.com/download
and then try to install the driver again
tried that but it still won,t install the drivers
still get error 536870347.i am beginnig to get really pissed off now

papasue
Posts: 4397
Joined: Sun Mar 16, 2008 2:08 pm
Location: CALIFORNIA
Contact:

Re: Sizzix eclips + Sure Cuts a Lot

Post by papasue »

Time to contact CraftEdge directly with your problem. Drop them a line here.

http://www.craftedge.com/support/support_form.html
Susan E
http://creationsbypapasue.blogspot.com
LEARN, GROW, CREATE, SHARE


Mac 10.12.6 Sierra, eCAL 1.506, ECAL2.023, SCAL4Pro, Export Plug-in, Inkscape 48, iPad/scal3
eClips2.

melchache
Posts: 41
Joined: Thu May 01, 2008 11:33 am

Re: Sizzix eclips + Sure Cuts a Lot

Post by melchache »

SO HAPPY NOW,I HAVE DOWNLOADED THE DRIVERS MYSELF.NOW JUST HAVE TO LEARN HOW TO USE THE SOFTWARE.I MAY BE GONE SOME TIME.....LA LA LA :D

jewellstwo
Posts: 4
Joined: Tue Nov 22, 2011 7:46 pm

Re: Sizzix eclips + Sure Cuts a Lot

Post by jewellstwo »

manangoes wrote:
jewellstwo wrote:I also am unable to install driver, and mine is the full version with registration #. I can't play either.
I just worked it out. Here is what I did.
Plugged in and turned on Eclips. Windows searched for driver and failed to install it.
I went to control panel and clicked on device manager.
Chose the 'unkown device' and chose to install device manually from my computer.
When it asked whereabouts on my computer I went to program files/craft edge/eclips/drivers as that is where I installed it. It found the driver and voila! :) Now I am happy :D
Hope it works for you too - I think I put down all the steps I did but I'm not sure as I was trying heaps of things to try and get it to work. Good luck, let me know how you go.
I just got back tot he forum this morning. I did exactly as you did, and now it says device working properly. Thanks SO MUCH YOU ARE AWESOME. I am going to try cutting soon.

melchache
Posts: 41
Joined: Thu May 01, 2008 11:33 am

Re: Sizzix eclips + Sure Cuts a Lot

Post by melchache »

JUST CUT OUT SOME LOVELY LACY FRAMES....AMAZING PIECE OF SOFTWARE

Post Reply